Web多人在线网络聊天系统:Fiora安装及使用


系统准备

  • 这里以centos7为例

开始安装

安装npm

yum update -y
curl -sL https://rpm.nodesource.com/setup_10.x | bash -
sudo yum install npm -y

安装nodesjs

npm install -g n
n 16.14.0 

安装Mongodb

#CentOS 7系统,将下面命令一起复制进SSH客户端运行
cat <<EOF > /etc/yum.repos.d/mongodb.repo
[mongodb-org-4.0]
name=MongoDB Repository
baseurl=https://repo.mongodb.org/yum/redhat/7/mongodb-org/4.0/x86_64/
gpgcheck=1
enabled=1
gpgkey=https://www.mongodb.org/static/pgp/server-4.0.asc
EOF
yum -y install mongodb-org

设置开机自启

#CentOS 7、Debian、Ubuntu系统
systemctl start mongod
systemctl enable mongod

安装Redis

yum install -y gcc
wget -P /opt http://download.redis.io/releases/redis-5.0.3.tar.gz
cd /opt
tar -zxvf redis-5.0.3.tar.gz
cd redis-5.0.3
make
make install PREFIX=/usr/local/redis
cp /opt/redis-5.0.3/redis.conf /usr/local/redis/bin/
# 然后需要更改一下 redis 的配置文件
vim /usr/local/redis/bin/redis.conf

修改 redis.conf 文件,把 daemonize no 改为 daemonize yes

后台启动

cd /usr/local/redis/bin/
./redis-server redis.conf

开机自启

vim /etc/systemd/system/redis.service
[Unit]
Description=redis-server
After=network.target

[Service]
Type=forking
ExecStart=/usr/local/redis/bin/redis-server /usr/local/redis/bin/redis.conf
PrivateTmp=true

[Install]
WantedBy=multi-user.target

设置开机启动

systemctl daemon-reload
systemctl start redis.service
systemctl enable redis.service

创建 redis 软链接

ln -s /usr/local/redis/bin/redis-cli /usr/bin/redis

常用服务操作命令

systemctl start redis.service   
#启动redis服务
systemctl stop redis.service   
#停止redis服务
systemctl restart redis.service   
#重新启动服务
systemctl status redis.service   
#查看服务当前状态
systemctl enable redis.service   
#设置开机自启动
systemctl disable redis.service   
#停止开机自启动

安装fiora

#拉取源码并存放于/opt文件夹
sudo yum install git -y
git clone https://github.com/yinxin630/fiora.git -b master /opt/fiora
cd /opt/fiora
#安装依赖,这里不能用npm,需要用yarn来安装
npm i -g yarn
yarn
#编译构建
npm run build

可能会遇到报错如下:


通过读源码发现实际命令如下:

#编译构建
npm run build:web

然后又有了一个新的报错

通过:https://itsmycode.com/error-digital-envelope-routines-unsupported/
得知,Node JS 版本 17 不是 LTS(Latest Stable Version),与 webpack 版本 4 不兼容。

解决方案 :将 Node.JS 降级到最新的稳定版本 (LTS)

yum remove nodejs -y
npm install -g n
n 16.14.0 

切换nodejs版本

n

选择已安装的版本

  ο node/16.14.0
    node/17.8.0

查看已安装版本

node -v


然后重新构建

#编译构建
npm run build:web


构建成功

# 启动
npm start
# 放行防火墙
#CentOS 7
firewall-cmd --zone=public --add-port=9200/tcp --permanent
firewall-cmd --reload



启动成功

管理配置

管理员配置

声明:我来时天晴,你来时风止|版权所有,违者必究|如未注明,均为原创|本网站采用BY-NC-SA协议进行授权

转载:转载请注明原文链接 - Web多人在线网络聊天系统:Fiora安装及使用


待到那一天,一手撑苍天,一眼俯人间。